Fixed moszoomimglink for zOOm 2.5.1

Well, it was easier than expected to port moszoomimglink to the new release of zOOm! All you have to do is install the new mambot after disabling the old one… Well, ok, not that easy, I haven't had a chance to repackage it yet.

To make your life bearable, though, I can tell you all that needs to be changed is the initiation sequence. In the file moszoomimglink.php, there is a long list of statements like the following:

        require_once($mosConfig_absolute_path.'/components/com_zoom/classes/zoom.class.php');

Instead of the long sequence, insert this:

 require_once($mosConfig_absolute_path.'/components/com_zoom/lib/zoom.class.php');
require_once($mosConfig_absolute_path.'/components/com_zoom/lib/toolbox.class.php');
require_once($mosConfig_absolute_path.'/components/com_zoom/lib/ftplib.class.php');
require_once($mosConfig_absolute_path.'/components/com_zoom/lib/pdf.class.php');
require_once($mosConfig_absolute_path.'/components/com_zoom/lib/editmon.class.php');
require_once($mosConfig_absolute_path.'/components/com_zoom/lib/gallery.class.php');
require_once($mosConfig_absolute_path.'/components/com_zoom/lib/image.class.php');
require_once($mosConfig_absolute_path.'/components/com_zoom/lib/comment.class.php');
require_once($mosConfig_absolute_path.'/components/com_zoom/lib/ecard.class.php');
require_once($mosConfig_absolute_path.'/components/com_zoom/lib/lightbox.class.php');
require_once($mosConfig_absolute_path.'/components/com_zoom/lib/privileges.class.php');
include_once($mosConfig_absolute_path."/components/com_zoom/lib/language/english.php");
global $zoomConfig, $zoom;
require($mosConfig_absolute_path."/components/com_zoom/etc/zoom_config.php");

And you are all set 

Add a Comment

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.