Prerequisites

Well, the utility is a command line tool that uses Perl - so that's a good start for requirements. You need some recent version of Perl: I used the tool only with 5.8.0 and appreciate feedback.

The packages required to run the utility are:

  • GD::Graph
  • POSIX
  • S710

GD::Graph

GD::Graph is the graphical core of the utility. It takes care of generating a graph given the data, and you as a user don't have to do more than presenting it and - voila! - it's there.

Unfortunately, the ease of use causes a little pain, since you'll have to download and install it. If you have access to an APT repository, then you should be fine after you type:

apt-get install perl-GD-Graph

Oh, and of course, if you don't have APT installed - then run and get it!

POSIX

The POSIX package is used for date and time manipulations, so it's not really a requirement and you could easily modify the code to do without. You can install it the same way as the other package , but POSIX should be installed by default on your Perl distribution.

So far, I have been unable to find an implementation of Perl POSIX on Windows, so if you are trying to get this to run on that OS, good luck!

S710

That's Dave's Perl package that wraps the S710 library. To install it, you'll probably want to go to his site and download both the S710 Linux software and the Perl wrapper (you'll need both to run the wrapper).

Dave did a splendid job at packaging the wrapper, and now it is extremely easy to use and does pretty much everything you'd want. (I think Dave likes it that we are using his software, so don't forget to stop by and say thanks!).

Download

You can download the software from the following links. For users of RedHat 9.0, I created two RPMs for the binary pieces: